Access local server from Extension

Not reproducible Issue #20482610

Details

Author
Erez G.
Created
Feb 10, 2019
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

We discovered the following:

  1. By default, we communicate with our CDN using xmlhttprequest to pull the json configuration file from our servers.
  2. Due to some security restrictions, we had to change this and we now host the file on a server in our internal network.
  3. Both the extension and the Edge browser failed to access our local network server and we got xhr status 0. When we configure the address (IP / domain) in the trusted site (under internet properties), it worked for the Edge but not for the Extension.
  4. Running our server on localhost worked only after we enabled “loopback”
  5. We installed fiddler, it gives the option to allow loopback through app container for applications. Only when checking “Extension” the traffic go through Fiddler and successfully reach out to the file.

It seems that as long as the Extension tries to access a file on the intranet it doesn’t work. We think it may be related to AppContainer network restriction but we would like to know what we should configure in order to fix the connection between our extension and the internal server.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Zachariah L.”

    • Hi Erez!

      Thank you for contacting us about this issue! Could you provide me with an implementation of your extension (or something similar to your implementation) to help me resolve this problem? 

      Thanks,

      Zach

    • At this time I will close out this issue. If you are still able to reproduce this issue then please provide the details we requested and I will resume investigating this issue.

      Best regards,​​​​​​​
      The Microsoft Edge Team.

    • Microsoft Edge Team

      Changed Status to “Not reproducible”

    You need to sign in to your Microsoft account to add a comment.

    Sign in